易语言采用穷举法实现搬砖

计算

窗口放置三个显示编辑框。

  1. .版本 2
  2.  
  3. .子程序 _计算图形按钮_被单击
  4. .局部变量 男人, 整数型
  5. .局部变量 女人, 整数型
  6. .局部变量 小孩, 整数型
  7.  
  8. .计次循环首 (9, 男人)  ' 一个男人搬4块砖,9个男人搬36块砖。
  9.     .计次循环首 (12, 女人)  ' 一个女人搬4块砖,9个女人搬36块砖。
  10.         .计次循环首 (36 × 2, 小孩)  ' 一个小孩搬4块砖,9个小孩搬36块砖。
  11.             .判断开始 (男人 + 女人 + 小孩 = 36 且 男人 × 4 + 女人 × 3 + 小孩 ÷ 2 = 36)
  12.                 男人编辑框.内容 = 到文本 (男人)
  13.                 女人编辑框.内容 = 到文本 (女人)
  14.                 小孩编辑框.内容 = 到文本 (小孩)
  15.                 跳出循环 ()  ' 找到后就跳出循环。
  16.             .默认
  17.  
  18.             .判断结束
  19.  
  20.         .计次循环尾 ()
  21.     .计次循环尾 ()
  22. .计次循环尾 ()

发布日期:

所属分类: 易语言 标签: