511遇见易语言软件本地注册验证-21-软件安全验证防止修改文件名称

软件安全验证提纲:

1、禁止软件名称更改
2、禁止窗口标题更改
3、禁止LOGO图标更改exescope、rehacker ,exescope, IcoSprite,程序图标,窗口图标
4、文件尺寸大小验证
4、MD5验证对比
5、CRC32验证对比
6、SHA1验证对比
7、花之令和加乱码
8、加壳反调试
9、暗桩
10、定时、延时、随机、多线程验证

防止修改文件名称源码:

.版本 2
 
.程序集 窗口程序集_启动窗口
 
.子程序 __启动窗口_创建完毕
 
随机验证 (511遇见.exe”)
 
.子程序 随机验证, , 公开
.参数 文件名称, 文本型, , 1
.局部变量 rm, 整数型
 
置随机数种子 ()
rm = 取随机数 (1, 2)
.判断开始 (rm = 1)
    判断文件名称 (文件名称)
.判断 (rm = 2)
    判断窗口标题 ()
.默认
 
.判断结束
 
.子程序 判断文件名称, , , 1
.参数 文件名称, 文本型
 
.判断开始 (取执行文件名 () ≠ 文件名称)
    ' 可以删除自身,可以销毁,可以死循环,可以客户机格式化C盘
    结束 ()
.默认
 
.判断结束
 
.子程序 判断窗口标题, , , 2
 
.子程序 _按钮1_被单击, , , 1
 
判断文件名称 (“511遇见.exe”)
 
.子程序 _按钮2_被单击, , , 2
 
判断窗口标题 ()


发布日期:

所属分类: 易语言