易语言数学经典算法求平方回文数

判断是否是回文数

.版本 2
.支持库 iext
 
.子程序 计算子程序, , , 判断是否是回文数
.参数 参数, 整数型
.局部变量 表项位置, 整数型
 
计数 = 0
显示超级列表框.全部删除 ()
.变量循环首 (1, 参数, 1, 循环变量)  ' *穷举n的取值范围*
    余数 = 0
    累计变量 = 1
    两数商 = 循环变量 × 循环变量  ' 计算 循环变量 的平方
    .判断循环首 (两数商 ≠ 0)
        数组 [数组下标] = 两数商 % 10  ' 从低到高分解数变量1的每一位数值存于数组
        两数商 = 两数商 ÷ 10
        数组下标 = 数组下标 + 1
    .判断循环尾 ()
    .判断循环首 (数组下标 > 1)  ' 将分解后的数字从低到高重新排序成新的数字
        余数 = 余数 + 数组 [数组下标 - 1] × 累计变量
        累计变量 = 累计变量 × 10
        数组下标 = 数组下标 - 1
    .判断循环尾 ()
    .如果真 (余数 = 循环变量 × 循环变量)
        计数 = 计数 + 1
        表项位置 = 显示超级列表框.插入表项 (, , , , , )  ' 显示结果
        显示超级列表框.置标题 (表项位置, 0, 到文本 (计数))
        显示超级列表框.置标题 (表项位置, 1, 到文本 (循环变量))
        显示超级列表框.置标题 (表项位置, 2, 到文本 (循环变量 × 循环变量))
    .如果真结束
 
.变量循环尾 ()

计算图形按钮

窗口放置一个超级列表框用来显示,一个编辑框输入范围。

.版本 2
 
.子程序 _计算图形按钮_被单击
.局部变量 输入数, 整数型
 
输入数 = 到数值 (输入编辑框.内容)
.如果 (输入数 ≤ 999999)  ' 判断输入数是否过大
    计算子程序 (输入数)
.否则
    信息框 (“您输入的数过大!”, #错误图标, “出现错误了:”)

发布日期:

所属分类: 易语言 标签: