易语言采用循环把十进制转为二进制数

程序集变量

.版本 2
 
.程序集 启动窗口程序集
.程序集变量 十进制数, 整数型
.程序集变量 余数组, 整数型, , "15"

转换源码

窗口放置两个编辑框,一个输入要转换的十进制数,一个用来显示转换后的二进制数。

.版本 2
 
.子程序 _计算图形按钮_被单击
.局部变量 标, 整数型
.局部变量 结果, 文本型
 
十进制数 = 到数值 (十进制数编辑框.内容)
.如果 (十进制数 > 1000000000 或 十进制数 ≤ 0)
    信息框 (“超出范围!”, 0, )
    结果编辑框.内容 = “”
.否则
    .变量循环首 (1, 15, 1,)
        ' 数组:余数组来存入二进制数
        加入成员 (余数组, 0)
    .变量循环尾 ()
    十进制数 = 到数值 (十进制数编辑框.内容)
    标 = 1  ' 初始化
    .判断循环首 (十进制数 > 0)
        ' 除二取余
        余数组 [标] = 十进制数 % 2
        十进制数 = 十进制数 ÷ 2
        ' 标志位自增1
        标 = 标 + 1
    .判断循环尾 ()
    .变量循环首 (标 - 1, 1, -1,)
        ' 转换成二进制数
        结果 = 结果 + 到文本 (余数组 [标])
    .变量循环尾 ()
    结果编辑框.内容 = “”
    结果编辑框.内容 = 结果

发布日期:

所属分类: 易语言 标签: