易语言教程取空白字节集和取重复字节集

取重复字节集

调用格式: 〈字节集〉 取重复字节集 (整数型 重复次数,字节集 待重复的字节集) - 系统核心支持库->字节集操作
英文名称:bin
返回一个字节集,其中包含指定次数的字节集重复结果。本命令为初级命令。
参数<1>的名称为“重复次数”,类型为“整数型(int)”。
参数<2>的名称为“待重复的字节集”,类型为“字节集(bin)”。该字节集将用于建立返回的字节集。如果为空,将返回一个空字节集。

操作系统需求: Windows、Linux

取空白字节集

调用格式: 〈字节集〉 取空白字节集 (整数型 零字节数目) - 系统核心支持库->字节集操作
英文名称:SpaceBin
返回具有特定数目 0 字节的字节集。本命令为初级命令。
参数<1>的名称为“零字节数目”,类型为“整数型(int)”。

操作系统需求: Windows、Linux

视频教程源码

.版本 2

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击, , , 取空白字节集
.局部变量 字节集变量, 字节集

字节集变量 = 取空白字节集 (200)
信息框 (“创建的空白字节集的长度为:” + 到文本 (取字节集长度 (字节集变量)), 0, , )

.子程序 _按钮2_被单击, , , 取重复字节集
.局部变量 字节集变量, 字节集

字节集变量 = 取重复字节集 (300, { 65 })
信息框 (“重复字节集的长度为:” + 到文本 (取字节集长度 (字节集变量)), 0, , )
编辑框1.内容 = “重复字节集变量中的内容为:” + #换行符 + 到文本 (字节集变量)


发布日期:

所属分类: 易语言 标签: