易语言教程文本操作-取文本长度(左边右边中间)无乱码

教程源码

.版本 2
.支持库 OPenGL

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击, , , 取文本长度

信息框 (取文本长度 (编辑框1.内容), 0, , )

.子程序 _按钮2_被单击, , , 取文本左边

编辑框3.内容 = 取文本左边 (编辑框1.内容, 4)

.子程序 _按钮3_被单击, , , 取文本右边

编辑框3.内容 = 取文本右边 (编辑框1.内容, 5)

.子程序 _按钮4_被单击, , , 取文本中间

编辑框3.内容 = 取文本中间 (编辑框1.内容, 4, 6)

.子程序 _按钮5_被单击, , , 取代码

' 取代码()返回值如果是负数,就是全角字符,否则就是半角字符
信息框 (取代码 (“编程”, ), 0, , )

.子程序 _按钮6_被单击, , , 删全部空

编辑框3.内容 = 删全部空 (编辑框1.内容)

.子程序 _按钮7_被单击, , , 删首空

编辑框3.内容 = 删首空 (编辑框1.内容)

.子程序 _按钮10_被单击, , , 到全角将文本中的半角字母、空格或数字变换为全角,返回变换后的结果文本

编辑框3.内容 = 到全角 (编辑框1.内容)

.子程序 _按钮11_被单击, , , 到半角 将文本中的全角字母、空格或数字变换为半角,返回变换后的结果文本。本命令为初级命令。

编辑框3.内容 = 到半角 (编辑框1.内容)

.子程序 取汉字, , , 取的是全角的字符
.参数 文本, 文本型

.子程序 _按钮12_被单击, , , 取汉字

编辑框2.内容 = “”
取汉字 (编辑框1.内容)

.子程序 取半角, , , 取半角
.参数 文本, 文本型
.局部变量 文本长度
.局部变量 字符位置

文本长度 = 取文本长度 (文本)
字符位置 = 0
.判断循环首 (字符位置 < 文本长度)
.如果 (是否为双字节字符 (文本, 字符位置))
字符位置 = 字符位置 + 1
.否则

编辑框2.加入文本 (取文本中间 (文本, 字符位置 + 1, 1))

.如果结束
字符位置 = 字符位置 + 1
.判断循环尾 ()

.子程序 _按钮13_被单击, , , 取全半字符

编辑框2.内容 = “”
取半角 (编辑框1.内容)

.子程序 取半角2
.参数 文本, 文本型
.局部变量 字符
.局部变量 文本长度
.局部变量 i, 整数型

文本长度 = 取文本长度 (文本)
.计次循环首 (文本长度, i)
字符 = 取代码 (文本, i)
.如果真 (字符 > 0)
编辑框3.加入文本 (取文本中间 (文本, i, 1))
.如果真结束

.计次循环尾 ()

.子程序 _按钮14_被单击, , , 取全半字符-2

取半角2 (编辑框1.内容)

.子程序 全角半角分离

.子程序 _按钮15_被单击, , , 全角半角分离
.局部变量 文本, 文本型
.局部变量 字符代码, 整数型

文本 = 到半角 (删全部空 (编辑框1.内容))
编辑框1.内容 = “”
编辑框2.内容 = “”
编辑框3.内容 = “”
.判断循环首 (文本 ≠ “”)
字符代码 = 取代码 (文本, )
.判断开始 (字符代码 = -95) ' 判断是否为句号
编辑框2.加入文本 (取文本左边 (文本, 2))
文本 = 取文本右边 (文本, 取文本长度 (文本) - 2)
.判断 (字符代码 < 0 或 字符代码 > 127)
编辑框3.加入文本 (取文本左边 (文本, 2))
文本 = 取文本右边 (文本, 取文本长度 (文本) - 2)
.默认
编辑框2.加入文本 (取文本左边 (文本, 1))
文本 = 取文本右边 (文本, 取文本长度 (文本) - 1)
.判断结束

.判断循环尾 ()


发布日期:

所属分类: 易语言 标签: