易语言教程窗口组件图片框属性

易语言图片框截图

易语言图片框

图片框属性教程源码:

.版本 2
.支持库 eCompress

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击

.如果 (图片框1.播放动画 = 假)
图片框1.播放动画 = 真
.否则
图片框1.播放动画 = 假
.如果结束

.子程序 _颜色选择器1_颜色被改变

图片框1.背景颜色 = 颜色选择器1.颜色

.子程序 _组合框1_列表项被选择

图片框1.边框 = 组合框1.现行选中项

.子程序 _按钮2_被单击

.如果真 (通用对话框1.打开 () = 真)
图片框1.图片 = 读入文件 (通用对话框1.文件名)
.如果真结束

.子程序 _组合框2_列表项被选择

图片框1.显示方式 = 组合框2.现行选中项

.子程序 __启动窗口_创建完毕
.局部变量 a
.局部变量 文件号
.局部变量 文本, 文本型, , "0"
.局部变量 m, 整数型

置随机数种子 ()
a = 取随机数 (1, 3)
图片框1.图片 = 读入文件 (取运行目录 () + “\” + 到文本 (a) + “.jpg”)

文件号 = 打开文件 (取运行目录 () + “\ml.txt”, , )

文本 = 分割文本 (读入文本 (文件号, ), #换行符, )
.计次循环首 (取数组成员数 (文本), m)

列表框1.插入项目 (m - 1, 文本 [m], )

.计次循环尾 ()

.子程序 _时钟1_周期事件
.局部变量 a

置随机数种子 ()
a = 取随机数 (1, 3)
图片框1.图片 = 读入文件 (取运行目录 () + “\” + 到文本 (a) + “.jpg”)

.子程序 _列表框1_列表项被选择
.局部变量 b

b = 列表框1.现行选中项
图片框1.图片 = 读入文件 (取运行目录 () + “\” + 到文本 (b + 1) + “.jpg”)

.子程序 _按钮3_被单击

写到文件 (取运行目录 () + “\image.zip”, #图片1)
延时 (1000)
ZIP压缩1.解压 (取运行目录 () + “\image.zip”, 取运行目录 ())

.子程序 _按钮4_被单击

时钟1.时钟周期 = 2000

教程下载:

1-40
百度网盘链接:https://pan.baidu.com/s/1qbtE2cgi9sU1vganeIuv7w
41-88
百度网盘链接:https://pan.baidu.com/s/1Yf0neUBcUtet_eNN0SzNnQ

提取码:加QQ群:521068947 群文件下载

511遇见全部视频教程百度网盘下载

资源教程交流①群:521068947

511遇见QQ: 272586593


发布日期:

所属分类: 易语言 标签: