第四课 VB.NET调用易语言编写的Dll

易语言DLL源码

.版本 2
 
.程序集 程序集1
 
.子程序 _启动子程序, 整数型, , 请在本子程序中放置动态链接库初始化代码
 
 
_临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
返回 (0)  ' 返回值被忽略。
 
.子程序 _临时子程序
 
' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
 
 
.子程序 add, 整数型, 公开
.参数 x, 整数型
.参数 y, 整数型
 
返回 (x + y)

VB.NET调用易语言Dll源码

Public Class Form1
    Public Declare Function add Lib "myadd.dll" (ByVal x As Int32, ByVal y As Int32) As Int32
    Private Sub Button1_Click(sender As Object, e As EventArgs) Handles Button1.Click
        TextBox3.Text = add(Val(TextBox1.Text), Val(TextBox2.Text))
    End Sub
End Class

优酷视频教程链接


发布日期:

所属分类: 易语言 标签: