SetWindowsHookExA键盘线程钩子注入DLL到游戏-2

整体步骤

1、钩子DLL
2、键盘钩子注入
3、把DLL注入到游戏

注入

.版本 2
 
.子程序 _按钮1_被单击, , , HOOK
 
消息钩子注入 (到数值 (编辑框1.内容), 编辑框2.内容, “hook”)

整数_到子程序指针

.版本 2
 
.子程序 整数_到子程序指针, 子程序指针
.参数 int, 整数型
 
置入代码 ({ 139, 69, 8, 137, 236, 93, 194, 4, 0 })
' mov eax,[ebp+8] 把第一参数存入 EAX 用作返回
' mov  esp,ebp  平衡栈
' pop ebp  从栈里取出
' ret 4
 
返回 (整数_到子程序指针 (0))

获取系统进程

.版本 2
.支持库 eAPI
 
.子程序 获取系统进程
.局部变量 进程列表, 进程信息, , "0"
.局部变量 进程, 文本型
.局部变量 i
 
进程列表 = 取系统进程列表 ()
.计次循环首 (取数组成员数 (进程列表), i)
    进程 = 进程列表 [i].进程名称
    组合框1.加入项目 (进程, )
.计次循环尾 ()

卸载钩子

.版本 2
 
.子程序 _按钮2_被单击
 
UnhookWindowsHookEx (hhook)

教程下载:

链接:https://pan.baidu.com/s/158ikKVjIwaoF4438MG4fhA

提取码:加QQ群:521068947 群文件下载


发布日期:

所属分类: 易语言 标签: