易语言创建进程暂停注入DLL编写

载入DLL

dll句柄 = LoadLibraryA (编辑框1.内容)

启动线程

.版本 2
.支持库 spec
.支持库 EThread
 
.局部变量 函数地址
.局部变量 内存地址
.局部变量 线程ID
.局部变量 线程句柄
 
函数地址 = GetProcAddress (dll句柄, 编辑框2.内容)
内存地址 = 申请内存 (取文本长度 (编辑框2.内容), )
写到内存 (编辑框2.内容, 内存地址, )
线程句柄 = CreateThread (0, 0, 函数地址, 内存地址, 0, 线程ID)
.如果真 (等待线程 (线程句柄, 100))
    关闭线程句柄 (线程句柄)
    释放内存 (内存地址)

注入DLL

在注入的DLL里我们采用启动线程的方式,载入窗口

.版本 2
.支持库 EThread
 
启动线程 (&th, , )
 
_临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
返回 (0)  ' 返回值被忽略。
 
.子程序 _临时子程序
 
' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
 
 
.子程序 th, , 公开
 
载入 (窗口1, , 真)

游戏的控制代码写在启动窗口创建后,支持大漠的注册和多线程,前面的例子已经贴出了代码。

教程下载:

链接:https://pan.baidu.com/s/158ikKVjIwaoF4438MG4fhA

提取码:加QQ群:521068947 群文件下载


发布日期:

所属分类: 易语言 标签: