第六课见易语言大漠一键登录-启动绑定游戏

一、启动游戏

.版本 2
 
.局部变量 i, 整数型
 
i = 0
.判断循环首 (i = 0)
    .如果 (进程_创建 (剑侠游戏路径, )0)
        i = 1
    .否则
        信息框 (“启动游戏失败”, 0, , )
        返回 ()
    .如果结束
 
.判断循环尾 ()

二、绑定游戏

.版本 2
.支持库 spec
 
.局部变量 i, 整数型
.局部变量 de_ret, 整数型
 
i = 0
.判断循环首 (i = 0)
    延时 (time)
    hwnd = FindWindow (, “剑侠情缘•网络版”, 1)
    ' hwnd = 窗口_取句柄 (, “剑侠情缘•网络版”)
    延时 (time)
    de_ret = BindWindow (hwnd, “dx”, “dx2”, “windows”, 0, 1)
    延时 (time)
    .如果 (de_ret = 1)
        _启动窗口.标签_绑定反馈.标题 = “绑定成功!”
        i = 1
 
    .否则
        _启动窗口.标签_绑定反馈.标题 = “绑定失败!”
 
    .如果结束
    调试输出 (de_ret)
.判断循环尾 ()

发布日期:

所属分类: 易语言 标签:   


下一篇:

没有了,已经是最新文章