易语言软件使用配置文件完成使用次数验证解锁


1、客户端需要获取机器码

2、解锁端需要获取机器码

3、二者比较绑定一致

4、解锁文件解锁成功后,必须删除,销毁

5、今天是要配置文件Ini

6、里面的次数需要加密

解锁端源码:

.版本 2
.支持库 dp1
 
.程序集 窗口程序集_启动窗口, , , 解锁端
 
.子程序 __启动窗口_创建完毕, , , 解锁端
.局部变量 a, 长整数型
.局部变量 b, 长整数型
 
.判断开始 (文件是否存在 (#reg) = 假)
    信息框 (“请先运行客户端!”, 0, , )
    结束 ()
.判断 (文件是否存在 (#reg))
    a = 到长整数 (到文本 (解密数据 (到字节集 (读配置项 (#reg, “特征”, “机器码”, )), “asdf”, #RC4算法)))
    b = 系统_取特征码综合 ()
    .判断开始 (a ≠ b)
        信息框 (“非法使用,即将销毁!”, 0, , )
        结束 ()
        程序_删除自身 ()
    .默认
 
    .判断结束
 
.默认
 
.判断结束
 
.子程序 _按钮1_被单击
 
.判断开始 (文件是否存在 (#timesfile))
    信息框 (“非法解锁!”, 0, , )
    结束 ()
.默认
    .如果真 (写配置项 (#timesfile, “次数”, “允许运行的次数”, “3”))
        置文件属性 (#timesfile, 2 + 4)
        信息框 (“解锁成功!”, 0, , )
        程序_删除自身 ()
    .如果真结束
 
.判断结束

使用次数限制源码:

.版本 2
.支持库 dp1
.支持库 spec
 
.程序集 窗口程序集_启动窗口, , , 软件
 
.子程序 __启动窗口_创建完毕, , , 软件
.局部变量 j, 长整数型
.局部变量 t, , , , 允许的总次数
.局部变量 n, , , , 已经运行的次数
 
j = 系统_取特征码综合 ()
.判断开始 (文件是否存在 (#reg) = 假)
    写配置项 (#reg, “特征”, “机器码”, 到文本 (加密数据 (到字节集 (到文本 (j)), “asdf”, #RC4算法)))
    置文件属性 (#reg, 2 + 4)

    信息框 (“请解锁后重新运行软件”, 0, , )
    结束 ()
.判断 (文件是否存在 (#timesfile))
    n = 到整数 (读配置项 (#timesfile, “次数”, “允许运行的次数”, ))
    t = 到整数 (读配置项 (#timesfile, “次数”, “已经运行的次数”, ))
    标题 = “软件剩余次数:  ” + 到文本 (n - t)
    调试输出 (n)
    调试输出 (t)
    .如果 (t > n)
        信息框 (“已经达到次数限制,试用结束,请联系作者。”, 0, , )
        删除文件 (#timesfile)
        结束 ()
    .否则
        t = t + 1
        写配置项 (#timesfile, “次数”, “已经运行的次数”, 到文本 (t))

    .如果结束
 
.默认
    信息框 (“请联系作者解锁”, 0, , )
    结束 ()
 
.判断结束


发布日期:

所属分类: 易语言 标签: