易语言教程数组操作删除成员方法2(封装子程序)

视频教程源码

.版本 2
.支持库 spec

.程序集 窗口程序集_启动窗口
.程序集变量 集_数组, 文本型, , "0"
.程序集变量 集_数组2, 整数型, , "0"

.子程序 __启动窗口_创建完毕

集_数组 = { “A”, “A”, “A”, “D”, “E”, “F”, “G”, “H”, “I”, “J”, “K” }
集_数组2 = { 1, 1, 1, 3, 4, 5, 6, 7, 8, 9, 10 }
' 采用循环遍历数组时,如果从后到前,逆向,会一次把重复的成员都删除
' 采用判断循环首时,两个重复的成员只删除一个

.子程序 _按钮1_被单击, , , 删除成员
.局部变量 数组, 整数型, , "2,3"
.局部变量 数组成员数
.局部变量 删除的数量

数组成员数 = 取数组成员数 (数组)
调试输出 (数组成员数)
删除的数量 = 删除成员 (数组, 3, 5)
数组成员数 = 取数组成员数 (数组)
调试输出 (删除的数量)
调试输出 (数组成员数)

.子程序 _按钮2_被单击, , , 删除成员-1(适合于删除一个指定成员)
.局部变量 数组, 文本型, , "0"
.局部变量 总数
.局部变量 m, 整数型

数组 = { “B”, “B”, “C”, “D”, “E”, “F”, “G”, “H”, “I”, “J”, “K” }
总数 = 取数组成员数 (数组)
.计次循环首 (总数, m)
.如果真 (数组 [m] = 编辑框1.内容)
删除成员 (数组, m, )
跳出循环 ()
.如果真结束

.计次循环尾 ()
调试输出 (数组)

.子程序 _按钮3_被单击, , , 删除成员-2(适合于删除多个指定成员)
.局部变量 数组, 文本型, , "0"
.局部变量 总数
.局部变量 m, 整数型

数组 = { “B”, “B”, “C”, “D”, “E”, “F”, “G”, “H”, “I”, “J” }
总数 = 取数组成员数 (数组)
.计次循环首 (总数, m)
.如果真 (数组 [总数 + 1 - m] = “B”)
删除成员 (数组, 总数 + 1 - m, )
.如果真结束

.计次循环尾 ()
调试输出 (数组)

.子程序 _按钮4_被单击, , , 删除成员-3
.局部变量 arr, 整数型, , "0"
.局部变量 i, 整数型
.局部变量 n, 整数型

加入成员 (arr, 0)
加入成员 (arr, 1)
加入成员 (arr, 2)
加入成员 (arr, 0)
加入成员 (arr, 3)
调试输出 (arr)
i = 取数组成员数 (arr)
n = 1
.判断循环首 (i ≥ n)
.如果 (arr [n] = 0)
删除成员 (arr, n, )
i = 取数组成员数 (arr)
n = 1

.否则

.如果结束
n = n + 1
.判断循环尾 ()
调试输出 (arr)

.子程序 _按钮5_被单击, , , 删除成员-4

子_删除成员 (集_数组, 编辑框1.内容)
调试输出 (集_数组)

.子程序 子_删除成员, , , 一次性删除重复的数据
.参数 参_account, 文本型, 数组
.参数 参_name, 文本型
.局部变量 total, 整数型
.局部变量 n, 整数型

total = 取数组成员数 (参_account)
.计次循环首 (total, n)
.如果真 (参_account [total + 1 - n] = 参_name)
删除成员 (参_account, total + 1 - n, )
.如果真结束

.计次循环尾 ()

.子程序 子_删除成员2, , , 具有删除重复成员的作用,会保留一个
.参数 参_arr, 整数型, 数组
.参数 参_name, 整数型
.局部变量 i
.局部变量 n

i = 取数组成员数 (参_arr)
n = 1
.判断循环首 (i ≥ n)
.如果 (参_arr [n] = 参_name)
删除成员 (参_arr, n, )
i = 取数组成员数 (参_arr)
n = 1

.否则

.如果结束
n = n + 1
.判断循环尾 ()

.子程序 _按钮6_被单击, , , 删除成员-5

子_删除成员2 (集_数组2, 到整数 (编辑框1.内容))
调试输出 (集_数组2)


发布日期:

所属分类: 易语言 标签: