易语言教程数组删除成员和删除指定成员

官方文档

调用格式: 〈整数型〉 删除成员 (通用型变量数组 欲删除成员的数组变量,整数型 欲删除的位置,[整数型 欲删除的成员数目]) - 系统核心支持库->数组操作
英文名称:RemoveElement
删除指定数组变量中的成员,并通过重新定义数组维数自动减少其成员数目。数组变量如为多维数组,删除完毕后将被转换为单维数组。返回所实际删除的成员数目。本命令为初级命令。
参数<1>的名称为“欲删除成员的数组变量”,类型为“通用型(all)”,提供参数数据时只能提供变量数组。
参数<2>的名称为“欲删除的位置”,类型为“整数型(int)”。位置值从 1 开始,如果小于 1 或大于第一个参数所指定数组变量的成员数目,将不会删除任何数据。
参数<3>的名称为“欲删除的成员数目”,类型为“整数型(int)”,可以被省略。本参数如果被省略,默认为 1 。

操作系统需求: Windows、Linux、Unix

教程源码

.版本 2
.支持库 spec

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕

.子程序 _按钮1_被单击, , , 删除成员
.局部变量 数组, 整数型, , "2,3"
.局部变量 数组成员数
.局部变量 删除的数量

数组成员数 = 取数组成员数 (数组)
调试输出 (数组成员数)
删除的数量 = 删除成员 (数组, 3, 5)
数组成员数 = 取数组成员数 (数组)
调试输出 (删除的数量)
调试输出 (数组成员数)

.子程序 _按钮2_被单击, , , 删除成员-1(适合于删除一个指定成员)
.局部变量 数组, 文本型, , "0"
.局部变量 总数
.局部变量 m, 整数型

数组 = { “A”, “B”, “C”, “D”, “E”, “F”, “G”, “H”, “I”, “J”, “K” }
总数 = 取数组成员数 (数组)
.计次循环首 (总数, m)
.如果真 (数组 [m] = 编辑框1.内容)
删除成员 (数组, m, )
跳出循环 ()
.如果真结束

.计次循环尾 ()
调试输出 (数组)

.子程序 _按钮3_被单击, , , 删除成员-2(适合于删除多个指定成员)
.局部变量 数组, 文本型, , "0"
.局部变量 总数
.局部变量 m, 整数型

数组 = { “A”, “B”, “C”, “D”, “E”, “F”, “G”, “H”, “I”, “J” }
总数 = 取数组成员数 (数组)
.计次循环首 (总数, m)
.如果真 (数组 [总数 + 1 - m] = “B”)
删除成员 (数组, 总数 + 1 - m, )
.如果真结束
.如果真 (数组 [总数 + 1 - m] = “D”)
删除成员 (数组, 总数 + 1 - m, )
.如果真结束

.计次循环尾 ()
调试输出 (数组)


发布日期:

所属分类: 易语言 标签: