易语言模块API视频教程线程删除许可证(DeleteCriticalSection)

------------------------------------------------------------
线程_删除许可证(DeleteCriticalSection)
------------------------------------------------------------
参数
lpCriticalSection

先前必须已将该对象初始化与InitializeCriticalSection函数中。

返回值

此函数无返回值

备注

删除关键节对象释放由该对象使用的所有系统资源。

API DeleteCriticalSection

.版本 2

.DLL命令 DeleteCriticalSection, , "kernel32", "DeleteCriticalSection", , 线程_删除许可证
.参数 lpCriticalSection, 线程许可证, 传址

模块源码

.版本 2

.子程序 线程_删除许可证, , 公开, 删除 由线程_创建许可证()的许可证
.参数 进入许可证, 线程许可证, 可空, 如果留空就删除所有已经创建的许可证
.局部变量 n, 整数型

.如果 (是否为空 (进入许可证))
.计次循环首 (取数组成员数 (集_许可证数组), n)
DeleteCriticalSection (进入许可证)
.计次循环尾 ()
清除数组 (集_许可证数组)
.否则
DeleteCriticalSection (进入许可证)


发布日期:

所属分类: 易语言 标签: