易语言应用接口支持库系统处理取CPU信息

取CPU信息

取CPU信息 命令 操作系统支持:Windows 所属类别:系统处理

取CPU信息。

语法: 无返回值 取CPU信息 (CPU信息)

参数名 描 述

CPU信息 必需的;CPU信息。待取得的CPU信息。

例程截图

取CPU信息。取CPU信息只能为以下内容:制造商、名称、时钟频率、描述、一级缓存大小、二级缓存大小、序列号、数据宽度。

511遇见

取CPU信息源码

.版本 2
.支持库 eAPI
.支持库 EChartBar
 
.子程序 _取CPU信息按钮_被单击
.局部变量 CPU信息, CPU信息
 
取CPU信息 (CPU信息)
信息框 (“CPU.制造商 :” + CPU信息.制造商 + “  CPU.名称 :” + CPU信息.名称 + “  CPU.时钟频率 :” + 到文本 (CPU信息.时钟频率) + “  CPU.描述 :” + CPU信息.描述 + “  CPU.一级缓存大小 :” + 到文本 (CPU信息.一级缓存大小) + “  CPU.二级缓存大小 :” + 到文本 (CPU信息.二级缓存大小) + “  CPU.序列号 :” + 到文本 (CPU信息.序列号) + “  CPU.数据宽度 :” + 到文本 (CPU信息.数据宽度), 0, )
 
.子程序 _取CPU占用率按钮_被单击
 
.如果 (逻辑标识 = 真)
    时钟1.时钟周期 = 1000
    逻辑标识 = 假
.否则
    时钟1.时钟周期 = 0
    逻辑标识 = 真
    CPU占用图.当前数据值 = 0
.如果结束
 
.子程序 _时钟1_周期事件
.局部变量 CPU占用率, 整数型
CPU占用率 = 取CPU占用率 ()
' CPU占用图.当前X轴标注文字 = 到文本 (CPU占用率)
CPU占用图.当前数据值 = CPU占用率

 


发布日期:

所属分类: 易语言 标签: