易语言教程选单选框分组框API全选取消

视频教程截图

易语言单选框

单选框分组框API全选取消源码:

.版本 2

.子程序 _单选框5_被单击

.如果真 (单选框5.选中)
运行 (读环境变量 (“windir”) + “\notepad.exe”, 假, )

.如果真结束

.子程序 _按钮1_被单击, , , 1--选中

SendMessageA (单选框6.取窗口句柄 (), 241, 1, 0)
SendMessageA (单选框7.取窗口句柄 (), 241, 1, 0)
SendMessageA (选择框1.取窗口句柄 (), 241, 1, 0)

.子程序 _按钮2_被单击

SendMessageA (单选框6.取窗口句柄 (), 241, 0, 0)
SendMessageA (单选框7.取窗口句柄 (), 241, 0, 0)
SendMessageA (选择框1.取窗口句柄 (), 241, 0, 0)

.子程序 _按钮3_被单击, , , PostMessageA

PostMessageA (单选框6.取窗口句柄 (), 241, 1, 0)
PostMessageA (单选框7.取窗口句柄 (), 241, 1, 0)
PostMessageA (选择框1.取窗口句柄 (), 241, 1, 0)

.子程序 _按钮4_被单击, , , PostMessageA

PostMessageA (单选框6.取窗口句柄 (), 241, 0, 0)
PostMessageA (单选框7.取窗口句柄 (), 241, 0, 0)
PostMessageA (选择框1.取窗口句柄 (), 241, 0, 0)

.子程序 _按钮5_被单击
.局部变量 id6
.局部变量 id7
.局部变量 id8

id6 = GetDlgCtrlID (单选框6.取窗口句柄 ())
id7 = GetDlgCtrlID (单选框7.取窗口句柄 ())
id8 = GetDlgCtrlID (选择框1.取窗口句柄 ())
' 调试输出 (CheckRadioButton (取窗口句柄 (), id6, id7, id6))

' CheckRadioButton (取窗口句柄 (), id6, id7, id7)
CheckDlgButton (取窗口句柄 (), id6, 1)
CheckDlgButton (取窗口句柄 (), id7, 1)

CheckDlgButton (取窗口句柄 (), id8, 1)

.子程序 _按钮6_被单击
.局部变量 id6
.局部变量 id7
.局部变量 id8

id6 = GetDlgCtrlID (单选框6.取窗口句柄 ())
id7 = GetDlgCtrlID (单选框7.取窗口句柄 ())
id8 = GetDlgCtrlID (选择框1.取窗口句柄 ())
' 调试输出 (CheckRadioButton (取窗口句柄 (), id6, id7, id6))

' CheckRadioButton (取窗口句柄 (), id6, id7, id7)
CheckDlgButton (取窗口句柄 (), id6, 0)
CheckDlgButton (取窗口句柄 (), id7, 0)
CheckDlgButton (取窗口句柄 (), id8, 0)

教程下载:

1-40
百度网盘链接:https://pan.baidu.com/s/1qbtE2cgi9sU1vganeIuv7w
41-88
百度网盘链接:https://pan.baidu.com/s/1Yf0neUBcUtet_eNN0SzNnQ

提取码:加QQ群:521068947 群文件下载

511遇见全部视频教程百度网盘下载

资源教程交流①群:521068947

511遇见QQ: 272586593


发布日期:

所属分类: 易语言 标签: