易语言乐玩插件FindColorEx找色扩展

乐玩模块源码:

.版本 2
 
.子程序 FindColorEx, 文本型, 公开
.参数 x1
.参数 y1
.参数 x2
.参数 y2
.参数 color, 文本型
.参数 sim, 小数型
.参数 dir
 
返回 (obj.文本方法 (“FindColorEx”, x1, y1, x2, y2, color, sim, dir))

乐玩找色扩展调用源码:

.版本 2
 
.子程序 _按钮7_被单击
.局部变量 str, 文本型
.局部变量 文本, 文本型, , "0"
.局部变量 temp, 文本型, , "0"
.局部变量 x
.局部变量 y
.局部变量 i, 整数型
.局部变量 m
.局部变量 n
 
str = l.FindColorEx (737, 136, 789, 197,117777-000000|ffeedd-000000”, 1, 2)
文本 = 分割文本 (str,|, )
.计次循环首 (取数组成员数 (文本), i)
    temp = 分割文本 (文本 [i],,, )
    .判断开始 (temp [1] = “1)
        x = 到整数 (temp [2])
        y = 到整数 (temp [3])
 
    .判断 (temp [1] = “2)
        m = 到整数 (temp [2])
        n = 到整数 (temp [3])
    .默认
 
    .判断结束
 
.计次循环尾 ()
 
l.MoveTo (x, y)
l.LeftDoubleClick ()
延时 (1000)
l.MoveTo (m, n)
l.LeftDoubleClick ()

教程下载:

链接:https://pan.baidu.com/s/1Z-GwQ84X7iccpK3NngsPZQ

提取码:加QQ群:521068947 群文件下载


发布日期:

所属分类: 易语言 标签: