511遇见易语言多线程大漠多线程-21易语言调用大漠插件

21-易语言调用大漠插件

一、COM组件注册
一个COM组件在使用前必须首先注册
手动注册
写到文件 (取运行目录 () + “\dm.dll”, #dm)
运行 (“regsvr32 dm.dll -s”, 真, )
dm.创建 ()
运行 (“regsvr32 ” + 取运行目录 () + “\dm.dll” + “ -s”, 真, )

二、易语言调用大漠插件

511遇见

1、易语言----工具---类型库或OCX组件---支持库
注册组件---
2、手动注册大漠到系统
3、免注册

教程源码:

.版本 2
 
.程序集 大漠, , 公开
.程序集变量 obj, 对象
 
.子程序 _初始化, , , 当基于本类的对象被创建后,此方法会被自动调用
 
.判断开始 (文件是否存在 (取运行目录 () + “\dm.dll”) = 假)
    .判断开始 (写到文件 (取运行目录 () + “\dm.dll”, #大漠) = 真)
        置文件属性 (取运行目录 () + “\dm.dll”, 24)
    .默认
 
    .判断结束
 
.默认
 
.判断结束
运行 (“regsvr32 dm.dll -s”,, #隐藏窗口)
obj.创建 (“dm.dmsoft”, )
.子程序 _销毁, , , 当基于本类的对象被销毁前,此方法会被自动调用
 
.子程序 Ver, 文本型, 公开
 
返回 (obj.文本方法 (“Ver”, ))


发布日期:

所属分类: 易语言 标签: