第六课 易语言调用VB.net编写的Dll

VB.net编写的Dll源码

<ComClass(ComClass1.ClassId, ComClass1.InterfaceId, ComClass1.EventsId)> _
Public Class ComClass1
 
#Region "COM GUID"
    ' 这些 GUID 提供此类的 COM 标识 
    ' 及其 COM 接口。若更改它们,则现有的
    ' 客户端将不再能访问此类。
    Public Const ClassId As String = "fa054a42-143e-44e3-a15a-91aa3590ca4e"
    Public Const InterfaceId As String = "8e5acda1-9f44-41dd-8a22-07c5818b7c53"
    Public Const EventsId As String = "bc0413bc-e703-43c9-8886-a6b7fbb24c75"
#End Region
 
    ' 可创建的 COM 类必须具有一个不带参数的 Public Sub New() 
    ' 否则, 将不会在 
    ' COM 注册表中注册此类,且无法通过
    ' CreateObject 创建此类。
    Public Function add(ByVal a As Integer, ByVal b As Integer) As Integer
        add = a + b
    End Function
 
    Public Function mysub(ByVal x As Integer, ByVal y As Integer) As Integer
 
        mysub = x - y
 
    End Function
 
End Class

易语言调用VB.net编写的Dll方式

.版本 2
 
.程序集 窗口程序集_启动窗口
.程序集变量 a, 类_vbnet
 
.子程序 _按钮1_被单击
 
编辑框3.内容 = 到文本 (a.add (到整数 (编辑框1.内容), 到整数 (编辑框2.内容)))
 
 
.子程序 _按钮2_被单击
 
编辑框6.内容 = 到文本 (a.sub (到整数 (编辑框4.内容), 到整数 (编辑框5.内容)))

优酷视频教程链接


发布日期:

所属分类: 易语言 标签: