易语言消息钩子监视窗口最大化最小化

安装消息钩子

.版本 2
 
.局部变量 ThreadID, 整数型
 
ThreadID = GetCurrentThreadId ()
Mhook = SetWindowsHookExA (4, &消息回调函数, GetModuleHandleA (0), ThreadID)

消息钩子回调函数

.版本 2
 
.子程序 消息回调函数, 整数型
.参数 nCode, 整数型, , 指定钩子子程序是否必须处理,小于0CallNextHookEx
.参数 wParam, 整数型, , 指定消息是否由当前线程发送,如果是,非0,否则,为0
.参数 lParam, 整数型, , 指向消息结构图的一个结构指针CWPSTRUCT
.局部变量 消息, CWPSTRUCT
 
 
.如果真 (nCode = 0)
    CopyMemory (消息, lParam, 20)
    .如果真 (消息.message274)
        .如果真 (消息.wParam61472)
            信息框 (“即将最小化窗口”, 0, , )
        .如果真结束
        .如果真 (消息.wParam61488)
            信息框 (“即将最大化窗口”, 0, , )
        .如果真结束
        .如果真 (消息.wParam61728)
            信息框 (“最大化还原恢复窗口”, 0, , )
        .如果真结束
        .如果真 (消息.wParam61536)
            信息框 (“准备关闭窗口!”, 0, , )
        .如果真结束
 
    .如果真结束
 
.如果真结束
 
返回 (CallNextHookEx (Mhook, nCode, wParam, lParam))

卸载消息钩子

UnhookWindowsHookEx (Mhook)

发布日期:

所属分类: 易语言 标签: