大漠多线程循环任务自动切换模板-4绑定启动线程

绑定启动线程源码:

.版本 2
.支持库 iext
.支持库 EThread
 
.子程序 _按钮_开始_被单击, , , 绑定,启动线程
.局部变量 n, 整数型
.局部变量 索引, 整数型
.局部变量 句柄, 整数型
 
.判断开始 (按钮_开始.标题 = “全部开始”)
    按钮_开始.标题 = “全部停止”
    超级延时 (100, )
    ' 判断一下,句柄
    .计次循环首 (窗口列表.取表项数 (), n)
        .如果真 (到整数 (窗口列表.取标题 (n - 1, 3)) = 0)
            按钮_开始.标题 = “全部开始”
            返回 ()
        .如果真结束
 
    .计次循环尾 ()
    .计次循环首 (窗口列表.取表项数 (), 索引)
        ' 创建线程内大漠对象
        线程 [索引].dm.创建 ()
        ' 设置线程内的全局路径
        线程 [索引].dm.SetPath (取运行目录 () + “\pic”)
        ' 设置字库
        ' 初始化线程运行状态=1
        线程 [索引].运行状态 = 1
        ' 获取句柄
        句柄 = 到整数 (窗口列表.取标题 (索引 - 1, 3))
        ' 设置游戏窗口标题
        线程 [索引].dm.SetWindowText (句柄, “剑侠情缘.网络版  目前自动任务第 ” + 到文本 (索引) + “ 个窗口”)
        ' 激活窗口
        线程 [索引].dm.SetWindowState (句柄, 1)
        ' 后台绑定
        线程 [索引].dm.BindWindow (句柄, “dx”, “dx2”, “windows”, 0)
        ' 降到CPu占用
        线程 [索引].dm.DownCpu (40)
        ' 开始启动线程
        启动线程 (&主线程, 索引, 线程 [索引].线程句柄)
        ' cpu
        线程_CPU优化 (线程 [索引].线程句柄)
    .计次循环尾 ()
 
 
.默认
    按钮_开始.标题 = “全部停止”
    ' ’停止()


发布日期:

所属分类: 易语言 标签: