易语言DLL制作调用及hook-注册表注入

注入DLL源码:

  1. .版本 2
  2. .支持库 EThread
  3.  
  4. .程序集 程序集1
  5.  
  6. .子程序 _启动子程序, 整数型, , 请在本子程序中放置动态链接库初始化代码
  7.  
  8. hook ()
  9. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  10. 返回 (0)  ' 返回值被忽略。
  11.  
  12. .子程序 _临时子程序
  13.  
  14. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  15.  
  16. .子程序 hook, , 公开
  17.  
  18. .如果真 (进程_ID取进程名 (进程_取自进程ID ()) = “calc.exe”)
  19.     启动线程 (&jiekou, , )
  20. .如果真结束
  21.  
  22. .子程序 jiekou
  23.  
  24. 载入 (窗口1, , 真)
  25. ------------------------------------窗口1源码:---------
  26. .版本 2
  27.  
  28. .程序集 窗口程序集_窗口1
  29.  
  30. .子程序 _按钮1_被单击
  31.  
  32. 信息框 (“注册表注入DLL 成功”, 0, , )

易语言注册表注入主程序:

.版本 2
 
.程序集 集_注册表注入
 
.子程序 注册表注入, 逻辑型
.参数 注入DLL, 文本型, , 注入的DLL 的路径
.局部变量 AppInit_DLLs值, 文本型
 
' 检测一下AppInit_DLLs下是否有DLL
AppInit_DLLs值 = 取文本注册项 (#本地机器, “SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Windows\AppInit_DLLs”, )
.如果真 (AppInit_DLLs值 ≠ “”)
    信息框 (“已存在注入的DLL,请先卸载”, 0, , )
    返回 (假)
.如果真结束
' 写入注册表中注入的DLL
写注册项 (#本地机器, “SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Windows\AppInit_DLLs”, 注入DLL)
AppInit_DLLs值 = 取文本注册项 (#本地机器, “SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Windows\AppInit_DLLs”, )
.如果真 (AppInit_DLLs值 ≠ 注入DLL)
    写注册项 (#本地机器, “SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Windows\AppInit_DLLs”, “”)
    信息框 (“注册注册表失败”, 0, , )
    返回 ()
 
.如果真结束
 
' LoadAppInit_DLLs改为1
写注册项 (#本地机器, “SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Windows\LoadAppInit_DLLs”, 1)
返回 (真)
 
.子程序 卸载注册表注入, 逻辑型
.局部变量 AppInit_DLLs值, 文本型
 
写注册项 (#本地机器, “SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Windows\AppInit_DLLs”, “”)
写注册项 (#本地机器, “SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Windows\LoadAppInit_DLLs”, 0)
' 检测一下AppInit_DLLs下是否有DLL
AppInit_DLLs值 = 取文本注册项 (#本地机器, “SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Windows\AppInit_DLLs”, )
.如果真 (AppInit_DLLs值 ≠ “”)
    信息框 (“卸载注册表注入失败,请手动卸载!”, 0, , )
    返回 ()
.如果真结束
 
返回 ()

教程下载:


发布日期:

所属分类: 易语言 标签: