易语言大漠单线程模块制作后台找字FindStrEx找多字打多怪

FindStrEx大漠接口说明

函数简介:
 
在屏幕范围(x1,y1,x2,y2),查找string(可以是任意字符串的组合),并返回符合color_format的所有坐标位置,相似度sim同Ocr接口描述.
 
(多色,差色查找类似于Ocr接口,不再重述)
 
函数原型:
 
string FindStrEx(x1,y1,x2,y2,string,color_format,sim)
 
参数定义:
 
x1 整形数:区域的左上X坐标
y1 整形数:区域的左上Y坐标
x2 整形数:区域的右下X坐标
y2 整形数:区域的右下Y坐标
string 字符串:待查找的字符串, 可以是字符串组合,比如"长安|洛阳|大雁塔",中间用"|"来分割字符串
color_format 字符串:颜色格式串, 可以包含换行分隔符,语法是","后加分割字符串. 具体可以查看下面的示例.注意,RGB和HSV格式都支持.
sim 双精度浮点数:相似度,取值范围0.1-1.0
 
返回值:
 
字符串:
返回所有找到的坐标集合,格式如下:
"id,x0,y0|id,x1,y1|......|id,xn,yn"
比如"0,100,20|2,30,40" 表示找到了两个,第一个,对应的是序号为0的字符串,坐标是(100,20),第二个是序号为2的字符串,坐标(30,40)
 
示例:
 
dm_ret = dm.FindStrEx(0,0,2000,2000,"长安|洛阳","9f2e3f-000000",1.0)
If len(dm_ret) > 0 Then
   ss = split(dm_ret,"|")
   index = 0
   count = UBound(ss) + 1
   Do While index < count
      TracePrint ss(index)
      sss = split(ss(index),",")
      id = int(sss(0))
      x = int(sss(1))
      y = int(sss(2))
      dm.MoveTo x,y
      Delay 1000
      index = index+1
   Loop
End If
 
注: 此函数的原理是先Ocr识别,然后再查找。所以速度比FindStrExFast要慢,尤其是在字库
很大,或者模糊度不为1.0时。
 
一般字库字符数量小于100左右,模糊度为1.0时,用FindStrEx要快一些,否则用FindStrFastEx.

模块源码

.版本 2
 
.子程序 FindStrEx, 文本型, 公开, 返回值:(返回字符串序号以及X和Y坐标,形式如"id,x0,y0|id,x1,y1|......|id,xn,yn")
.参数 x1, 整数型, , x1 整形数:区域的左上X坐标
.参数 y1, 整数型, , y1 整形数:区域的左上Y坐标
.参数 x2, 整数型, , x2 整形数:区域的右下X坐标
.参数 y2, 整数型, , y2 整形数:区域的右下Y坐标
.参数 string, 文本型, , string 字符串:待查找的字符串,可以是字符串组合,比如"长安|洛阳|大雁塔",中间用"|"来分割字符串
.参数 color_format, 文本型, , color_format 字符串:颜色格式串, 可以包含换行分隔符,语法是","后加分割字符串. 注意,RGB和HSV格式都支持.
.参数 sim, 双精度小数型, , sim 双精度浮点数:相似度,取值范围0.1-1.0
 
返回 (obj.文本方法 (“FindStrEx”, x1, y1, x2, y2, string, color_format, sim))

《剑侠情缘》测试源码

.版本 2
.支持库 spec
 
.子程序 _按钮7_被单击, , , FindStrEx
.局部变量 tmp, 文本型
.局部变量 ss, 文本型, , "0"
.局部变量 sss, 文本型, , "0"
.局部变量 count, 整数型
.局部变量 x, 整数型
.局部变量 y, 整数型
.局部变量 i, 整数型
 
tmp = FindStrEx (0, 0, 2000, 2000, “天盾|鬼谷|墨攻|尚贤”, “ebb200-000000”, 1)
' “1,35,251|0,36,268”
调试输出 (tmp)
.如果 (取文本长度 (tmp) > 0)
    ss = 分割文本 (tmp, “|”, )
    count = 取数组下标 (ss, )
    .计次循环首 (count, i)
        处理事件 ()
        sss = 分割文本 (ss [i], “,”, )
        x = 到整数 (sss [2])
        y = 到整数 (sss [3])
        调试输出 (到文本 (x) + “,” + 到文本 (y))
        MoveTo (x, y)
        延时 (500)
        LeftClick ()
        延时 (500)
    .计次循环尾 ()
 
 
.否则

视频教程优酷土豆链接:


发布日期:

所属分类: 易语言 标签: