易语言CreateWindowEx创建浏览器

CreateWindowEx

.版本 2
 
.DLL命令 _CreateWindowEx, 整数型, "user32", "CreateWindowExA"
    .参数 dwExStyle, 整数型
    .参数 lpClassName, 文本型
    .参数 lpWindowName, 文本型
    .参数 dwStyle, 整数型
    .参数 x, 整数型
    .参数 y, 整数型
    .参数 nWidth, 整数型
    .参数 nHeight, 整数型
    .参数 hWndParent, 整数型
    .参数 hMenu, 整数型
    .参数 hInstance, 整数型
    .参数 lpParam, 整数型

函数原型

CreateWindowEx函数创建一个层叠的,自动弹出的(pop-up)或是一个子窗口通过扩展格式。另外这个函数的作用与CreateWindow函数的作用相同。要获得更多的关于创建窗口的信息和关于CreateWindowEx函数参数的详细描述。

HWND CreateWindowEx(
DWORD DdwExStyle,        //窗口的扩展风格
LPCTSTR lpClassName,    //指向注册类名的指针
LPCTSTR lpWindowName,   //指向窗口名称的指针
DWORD dwStyle,          //窗口风格
int x,                  //窗口的水平位置
int y,                  //窗口的垂直位置
int nWidth,             //窗口的宽度
int nHeight,            //窗口的高度
HWND hWndParent,        //父窗口的句柄
HMENU hMenu,            //菜单的句柄或是子窗口的标识符
HINSTANCE hInstance,    //应用程序实例的句柄
LPVOID lpParam          //指向窗口的创建数据
);

封装创建浏览器

.版本 2
.支持库 spec
 
.子程序 CreatehtmlWin
.参数 hwnd
.参数 hWndTxt, 文本型
.参数 X
.参数 Y
.参数 cx
.参数 cy
 
调试输出 (AtlAxWinInit ())
调试输出 (_CreateWindowEx (#WS_EX_CLIENTEDGE, “AtlAxWin”, hWndTxt, 位或 (#WS_CHILD, #WS_VISIBLE, #WS_HSCROLL, #WS_VSCROLL), X, Y, cx, cy, hwnd, 1, 0, 0))

调用测试

CreatehtmlWin (_启动窗口.取窗口句柄 (), “http://www.511yj.com”, 10, 10, 400, 300)

用到的其他API

.版本 2
 
.DLL命令 _CoInitialize, , "ole32.dll", "CoInitialize"
    .参数 pvReserved, 整数型
 
.DLL命令 _CoUninitialize, , "ole32.dll", "CoUninitialize"
 
.DLL命令 AtlAxWinInit, 整数型, "atl.dll"
 
.DLL命令 _CreateWindowEx, 整数型, "user32", "CreateWindowExA"
    .参数 dwExStyle, 整数型
    .参数 lpClassName, 文本型
    .参数 lpWindowName, 文本型
    .参数 dwStyle, 整数型
    .参数 x, 整数型
    .参数 y, 整数型
    .参数 nWidth, 整数型
    .参数 nHeight, 整数型
    .参数 hWndParent, 整数型
    .参数 hMenu, 整数型
    .参数 hInstance, 整数型
    .参数 lpParam, 整数型
 
.DLL命令 _DestroyWindow, 整数型, , "DestroyWindow"
    .参数 hwnd, 整数型

发布日期:

所属分类: 易语言 标签: