安卓模拟器易语言adb模块制作查看模拟器设备(adb devices)

安卓模拟器

目前市面上安卓模拟器软件看着种类繁多,但其实只有两大流派:Bluestacks(蓝叠)和Virtualbox。
Bluestacks的历史可以追溯到2011年,是最早在PC上实现流畅运行安卓系统的方案。Bluestacks的原理是把Android底层API接口翻译成Windows API,对PC硬件本身没有要求,在硬件兼容性方面有一定的优势。但Bluestacks需要翻译的Android接口数量巨大,很难面面俱到,而且存在软件翻译的开销,在性能和游戏兼容性方面欠佳。
Virtualbox是数据库巨头Oracle旗下的开源项目,通过在Windows内核底层直接插入驱动模块,创建一个完整虚拟的电脑环境运行安卓系统,加上CPU VT硬件加速,性能和兼容性都更好,但是对于电脑CPU有一定要求,超过五年以上的电脑使用起来比较吃力。
国内像靠谱助手、新浪手游助手等一大批手游助手类都是直接基于Bluestacks内核,因为Bluestacks没有公开源代码无法深度定制,只能简单的优化,再包装界面后上市。其他的像海马玩、逍遥安卓、夜神、ITools这类的产品都是基于Virtualbox,能力弱的(如海马玩、ITools)直接采用Oracle发布的Virtualbox商业版,能力强的(如逍遥安卓、夜神)则对Virtualbox源代码深度定制后重新编译来进一步提高性能和兼容性。
每个安卓模拟器有其各自特点,但都不能尽善尽美,用户在选择适合自己的安卓模拟器的时候,需要根据自己的实际情况对不同安卓模拟器进行选择:
xxx
印度公司研发。对于国内部分流行游戏兼容性没有及时支持。受制于内核技术,虽然推出时间长,但是游戏兼容性,尤其是性能欠佳。
2、靠谱助手(天天)
国内最早(2013年开始)基于Bluestacks内核的安卓模拟器,优化了使用界面。但是靠谱缺少属于自己的内核技术,在兼容性和性能方面需要提升,产品不成熟。
3、海马玩
国内首款基于Oracle Virtualbox商业版的安卓模拟器,2014年底产品推出时与Bluestacks内核的安卓模拟器形成鲜明对比,版本与功能更新速度慢,弹出广告插件多,占用资源明显。
4、逍遥安卓
2015年中推出的基于Virtualbox深度定制的安卓模拟器。业界首创的一键多开是其亮点,国内独家支持安卓5.1.1。版本更新快,需求响应及时。模拟器性能和兼容性均不错,流畅、口碑好。
5、夜神模拟器
另一款基于Virtualbox定制的安卓模拟器,直接集成NOVA桌面是它的一大特色。但多开效率需进行提升。卡顿、延迟、偶发性系统奔溃、不流畅。
声明:
教程需要 取DOS返回值:
教程已经发布在优酷
511遇见易语言模块API制作 - 播单 - 优酷视频 http://list.youku.com/albumlist/show/id_50740768
对ADB 支持最好的是雷电和逍遥
教程采用的模拟器
【雷电模拟器】

第一课:查看模拟器设备

  1. adb devices
  2. List of devices attached
  3. 127.0.0.1:5555  device
  4. 127.0.0.1:5557  device

视频教程源码

  1. .版本 2
  2.  
  3. .子程序 查看模拟器设备, 文本型, 公开, 成功返回:“Succes:IP:端口"
  4. .局部变量 tmp, 文本型
  5. .局部变量 数组, 文本型, , "0"
  6. .局部变量 i, 整数型
  7. .局部变量 临时, 文本型
  8. .局部变量 返回文本, 文本型
  9.  
  10. tmp = 取DOS命令 (“adb devices”)
  11. .如果真 (寻找文本 (tmp, “device”, , 假) ≠ -1)
  12.     数组 = 分割文本 (tmp, “attached”, )
  13.     .如果真 (取数组成员数 (数组) ≥ 2)
  14.         数组 = 分割文本 (数组 [2], “device”, )
  15.     .如果真结束
  16.     .计次循环首 (取数组成员数 (数组), i)
  17.         临时 = 删全部空 (子文本替换 (子文本替换 (数组 [i], 字符 (9), , , , 真), #换行符, , , , 真))
  18.         .如果真 (临时 ≠ “”)
  19.             返回文本 = 返回文本 + 临时 + “|”
  20.         .如果真结束
  21.  
  22.     .计次循环尾 ()
  23.     返回 (“success:” + 返回文本)
  24. .如果真结束
  25.  
  26. 返回 (tmp)


发布日期:

所属分类: 易语言 标签: