安卓模拟器易语言adb模块adb初始化

1、解决:adb devices时显示的XXXXXXXX offline

> adb devices
List of devices attached
emulator-5554   device
127.0.0.1:5555  offline
> adb start-server
* daemon not running. starting it now on port 5037 *
* daemon started successfully *

错误原因分析:

1、有程序占用5555端口,导致adb认为5554不能作为第1个设备启用
2、这种情况大部分是安装的手机助手之类的软件占用了5555端口造成的。卸载掉就OK了。
3、adb.exe自身进程问题
4、emulator的 console 端口是 5554,而adb 的端口是console端口 +1 就是 5555

解决方案:

结束ADB.EXE进程

  1. adb kill-server
  2. adb start-server
  3.  
  4. emulator-5554
  5. 127.0.0.1:5557
  6. 127.0.0.1:5559
  7. 127.0.0.1:5561

视频教程模块源码:

.版本 2
 
.子程序 adb_初始化
.局部变量 temp, 文本型
.局部变量 返回文本, 文本型
.局部变量 str, 整数型
 
temp = 取DOS命令 (“adb devices”)
.如果 (寻找文本 (temp, “offline”, ,)-1)
    取DOS命令 (“adb kill-server”)
    延时 (2000)
    .循环判断首 ()
        返回文本 = 取DOS命令 (“adb start-server”)
        str = 寻找文本 (返回文本, “successfully”, ,)
        .' 如果 (str ≠ -1)
            ' 跳出循环 ()
        .否则
 
        .如果结束
 
    .循环判断尾 (str = -1)
 
.否则


发布日期:

所属分类: 易语言 标签: