安卓模拟器易语言adb模块adb初始化

1、解决:adb devices时显示的XXXXXXXX offline

  1. > adb devices
  2. List of devices attached
  3. emulator-5554   device
  4. 127.0.0.1:5555  offline
  5. > adb start-server
  6. * daemon not running. starting it now on port 5037 *
  7. * daemon started successfully *

错误原因分析:

1、有程序占用5555端口,导致adb认为5554不能作为第1个设备启用
2、这种情况大部分是安装的手机助手之类的软件占用了5555端口造成的。卸载掉就OK了。
3、adb.exe自身进程问题
4、emulator的 console 端口是 5554,而adb 的端口是console端口 +1 就是 5555

解决方案:

结束ADB.EXE进程

  1. adb kill-server
  2. adb start-server

视频教程模块源码:

  1. .版本 2
  2.  
  3. .子程序 adb_初始化
  4. .局部变量 temp, 文本型
  5. .局部变量 返回文本, 文本型
  6. .局部变量 str, 整数型
  7.  
  8. temp = 取DOS命令 (“adb devices”)
  9. .如果 (寻找文本 (temp, “offline”, ,)-1)
  10.     取DOS命令 (“adb kill-server”)
  11.     延时 (2000)
  12.     .循环判断首 ()
  13.         返回文本 = 取DOS命令 (“adb start-server”)
  14.         str = 寻找文本 (返回文本, “successfully”, ,)
  15.         .' 如果 (str ≠ -1)
  16.             ' 跳出循环 ()
  17.         .否则
  18.  
  19.         .如果结束
  20.  
  21.     .循环判断尾 (str = -1)
  22.  
  23. .否则


发布日期:

所属分类: 易语言 标签: