易语言大漠单线程模块制作获取窗口客户区域句柄等

模块命令源码:

.版本 2

.子程序 GetClientRect, 整数型, 公开, 获取窗口客户区域在屏幕上的位置GetClientRect(返回值:0失败,1成功)
.参数 hwnd, 整数型, , 指定的窗口句柄
.参数 x1, 整数型, 参考, 返回窗口客户区左上角X坐标
.参数 y1, 整数型, 参考, 返回窗口客户区左上角Y坐标
.参数 x2, 整数型, 参考, 返回窗口客户区右下角X坐标
.参数 y2, 整数型, 参考, 返回窗口客户区右下角Y坐标

返回 (obj.数值方法 (“GetClientRect”, hwnd, x1, y1, x2, y2))

.子程序 GetClientSize, 整数型, 公开, 获取窗口客户区域的宽度和高度GetClientSize(返回值:0失败,1成功)
.参数 hwnd, 整数型, , 指定的窗口句柄
.参数 width, 整数型, 参考, 宽度
.参数 height, 整数型, 参考, 高度

返回 (obj.数值方法 (“GetClientSize”, hwnd, width, height))

.子程序 GetForegroundFocus, 整数型, 公开, 获取顶层活动窗口中具有输入焦点的窗口句柄GetForegroundFocus(返回整型表示的窗口句柄)

返回 (obj.数值方法 (“GetForegroundFocus”, ))

.子程序 GetForegroundWindow, , 公开, 获取顶层活动窗口的句柄GetForegroundWindow(返回整型表示的窗口句柄)

返回 (obj.数值方法 (“GetForegroundWindow”, ))

.子程序 GetPointWindow, 整数型, 公开, 获取给定坐标的可见窗口句柄GetPointWindow(返回整型表示的窗口句柄)
.参数 x, 整数型, , 屏幕X坐标
.参数 y, 整数型, , 屏幕Y坐标

返回 (obj.数值方法 (“GetPointWindow”, x, y))

.子程序 GetProcessInfo, 文本型, 公开, 根据指定的pid获取进程详细信息,(进程名,进程全路径,CPU占用率(百分比),内存占用量(字节))GetProcessInfo
.参数 pid, 整数型, , 进程pid

返回 (obj.数值方法 (“GetPointWindow”, pid))

.子程序 GetSpecialWindow, 整数型, 公开, 获取特殊窗口GetSpecialWindow(返回整型表示的窗口句柄)
.参数 Flag, 整数型, , 0 : 获取桌面窗口;1 : 获取任务栏窗口

返回 (obj.数值方法 (“GetSpecialWindow”, Flag))

.子程序 GetWindow, 整数型, , 获取给定窗口相关的窗口句柄GetWindow
.参数 hwnd, 整数型, , 窗口句柄
.参数 flag, 整数型, , 0 : 获取父窗口1 : 获取第一个儿子窗口2 : 获取First 窗口3 : 获取Last窗口4 : 获取下一个窗口5 : 获取上一个窗口6 : 获取拥有者窗口7 : 获取顶层窗口

返回 (obj.数值方法 (“GetWindow”, hwnd, flag))

视频教程优酷土豆链接:


发布日期:

所属分类: 易语言 标签: