511遇见易语言多线程大漠多线程-23大漠免注册类模块制作方法1

23大漠免注册类模块制作方法1

1、类模块
2、免注册

模块源码:

.版本 2

.程序集 大漠, , 公开
.程序集变量 obj, 对象

.子程序 _初始化, , , 当基于本类的对象被创建后,此方法会被自动调用

.子程序 _销毁, , , 当基于本类的对象被销毁前,此方法会被自动调用

释放 ()

.子程序 初始化并注册, 逻辑型, 公开, 返回假收费注册失败
.参数 注册码, 文本型, 可空
.参数 附加信息, 文本型, 可空
.参数 插件路径, 文本型, 可空
.参数 是否收费, 逻辑型, 可空, 为空为加免费

.判断开始 (是否收费 = 真)
创建目录 (#路径)
置文件属性 (#路径, 2 + 4 + 32)
写到文件 (#路径 + “\dm71830.dll”, #dm71830)
置文件属性 (#路径 + “\dm71830.dll”, 2 + 4 + 32)
动态调用插件 (#路径 + “\dm71830.dll”)
.判断 (是否收费 = 假 且 是否为空 (插件路径))
创建目录 (#路径)
置文件属性 (#路径, 2 + 4 + 32)
写到文件 (#路径 + “\dm31233.dll”, #dm31233)
置文件属性 (#路径 + “\dm31233.dll”, 2 + 4 + 32)
动态调用插件 (#路径 + “\dm31233.dll”)

.判断 (是否为空 (插件路径) = 假)
动态调用插件 (插件路径)
.默认

.判断结束
obj.创建 (“dm.dmsoft”, )
.判断开始 (obj.数值方法 (“reg”, 注册码, 附加信息) ≠ 1)
返回 (假)
.默认
返回 (真)
.判断结束

.子程序 创建, , 公开

释放 ()
obj.创建 (“dm.dmsoft”, )
SetParam64ToPointer ()

.子程序 释放, , 公开

obj.清除 ()

.子程序 GetZjjAddr, 整数型, 公开, 获取字节集的数据地址


发布日期:

所属分类: 易语言 标签: