易语言多线程大漠多线程-34大漠多线程模板-4多线程初始化

多线程初始化

.版本 2
 
.子程序 多线程_初始化
.局部变量 i, 整数型
 
MaxHwnd = 100
.计次循环首 (MaxHwnd × 2, i)
    ' 防止避免多线程访问文本型变量引发的数据冲突,预先分配好内存地址
    线程信息 [i].任务状态 = 取空白文本 (100)
    线程信息 [i].任务状态 = 取空白文本 (100)
    多线程复位 (i)
.计次循环尾 ()
 
.子程序 多线程复位
.参数 索引, 整数型
 
.如果真 (索引 ≤ 0 或 索引 ≥ MaxHwnd × 2)
    返回 ()
.如果真结束
 
线程信息 [索引].窗口句柄 = 0
线程信息 [索引].线程句柄 = 0
线程信息 [索引].是否暂停 = 假
线程信息 [索引].是否结束 = 假
线程信息 [索引].进程PID = 0
线程信息 [索引].线程状态 = #线程状态_未启动
线程信息 [索引].异常状态 = “”
 
.子程序 多线程_取空余位置, 整数型, , 从MaxHwnd中找到没有启动的线程位置,返回这个线程的序号
.局部变量 i, 整数型
 
.计次循环首 (MaxHwnd, i)
    .如果真 (线程信息 [i].线程句柄 = 0)
        返回 (i)
    .如果真结束
 
.计次循环尾 ()
返回 (-1)


发布日期:

所属分类: 易语言 标签: