无需升级,您的WordPress数据库已经是最新的了-后台登录跳转首页

今天在线升级了wp4.6.1版本,后台登录时出现了“无需升级,您的WordPress数据库已经是最新的了”如下图,点击继续回到首页,出现死循环,致使网站后台无法登录,搜索了一下解决方案,分享处理过程如下:

511遇见

一、 问题出现原因

出现这种现象的用户多数是启用了Memcached缓存!在wp-content文件夹有object-cache.php文件,这是造成缓存无法登录的主要原因。

二、解决方案

1、删除或更名 object-cache.php
我们只需要进入wp-content文件夹把object-cache.php文件删除,或者更改后缀名称,比如object-cache.php.bak 再次登录就不会出现死循环了。显然这样是不科学的,影响了Memcached缓存!登录成功后你把object-cache.php改回原来的名字,问题依然存在。
2、安装 WP Memcached Manager 插件
搜索一下WP Memcached Manager插件,发现已经7年没有更新了,当时很怀疑,还是点击安装->启用插件,再把刚刚重命名文件改回去,这时你再次登录就不会出现以上问题了。至于这个插件,你现在完全可以卸载掉了。


发布日期:

所属分类: Wordpress 综合 标签: