易语言循环检验取两个数的最小公倍数

源码

窗口需要两个编辑框,分别放置两个自然数。第三个编辑框,用来放置最小公倍数。

.版本 2

.子程序 _计算图形按钮_被单击
.局部变量 第一个数, 整数型
.局部变量 第二个数, 整数型

第一个数 = 到数值 (首数编辑框.内容)
第二个数 = 到数值 (二数编辑框.内容)
.如果真 (第一个数 = 0 或 第二个数 = 0)
信息框 (“数值不能为0”, #错误图标, “出现错误了!”)
返回 ()
.如果真结束
结果编辑框.内容 = 到文本 (取得两个整数的最小公倍数 (第一个数, 第二个数))

.子程序 取得两个整数的最小公倍数, 整数型
.参数 第一数, 整数型
.参数 第二数, 整数型
.局部变量 操作数甲, 整数型
.局部变量 操作数乙, 整数型
.局部变量 中间数, 整数型

操作数甲 = 第一数 ' 第一个数
操作数乙 = 第二数 ' 第二个数
中间数 = 操作数甲
.判断循环首 (中间数 % 操作数乙 ≠ 0) ' 如果取余得0则跳出
' 如果不成功,中间数翻倍
中间数 = 中间数 + 操作数甲
.判断循环尾 ()
' 中间数即是所要的最小公倍数
返回 (中间数)


发布日期:

所属分类: 易语言 标签: